Bug Filed on 06-06-2016: Install Agent issue on PIZero [work around: press enter]

What dashboard are you using? (Web, iOS, Android)
Web ( Browser Google Chrome)

What OS? (Jessie, Wheezy)

What Model Pi?
PIZero version 1
PIZero version 2

Please describe the bug / issue. Attaching any relevant screenshots would be very helpful!

I have added a PI 2 no problem to cayenne and it shows up in my dashboard, but attempting to adding 2 different versions of the PI Zero It gets stuck on the Agent install part.

I have read other posts on this and checked that I have disk space etc using df -h

The part it gets stuck on is shown here:

All Raspberry PIs are on the same network controlled by me with no firewall issues, the PI 2 works as expected in the dashboard, all PIs are using the same version of the Jessie OS, its only the PI Zeros that have issues.

The Agent install does not create an error it just hangs where I cannot quit out of the SSH session I am installing it with. Any help appreciated as I love the potential of using cayenne to monitor my robots and sensors.

Hey @elliot5555,

Just confirming here. You used a separate install token for your zeros, correct? …you didn’t use the same install that you used on your Pi 2.


Yes correct I generated the new install URLs using the dashboard, both install urls /scripts were unique and I still have them showing in my dashboard as pending or the hour glass symbol against the devices, the PI Zeros have also been recently updated.

Got it. I appreciate you investing the time before hand to list out the actions you’ve tried. It helps narrow things down :slight_smile:

We’re going to do some tests on our side. I cannot see reason right now why it would not install on your zero. Esp. if it installed fine on your Pi 2. I also assume you are not using Jessie Lite.

I’ll report back here with more info, or to ask you additional questions. If you have any ideas @Ian @ats1080s feel free to explore and ask too.


Just to make sure I was doing the right thing I just ran the same routine on a new PI 3 I had, it went through straight away and below is a screenshot of my dashboard with now both a PI2 and PI3 working correctly with both Zeros showing as pending, and yes both Zeros have the full Jessie OS, now I have thought of one thing that may be a factor, What I have done to build my SD cards for the Zeros, I installed new on my PI2 then added all software i wanted, and then cloned the SD card onto 2 x new SD cards for my PI Zero’s, I then changed just their hostnames once they were up and running, so thinking about this is there something that could be causing an issue where something on each of the Zeros is conflicting with the Agent install part, its just a thought but thats the only common factor I can think of, my PI 3 was build standalone and not a copy

Would you be able to attempt a standalone build on the zero just to see if that’s root cause?


I will try that as these Zeros are part of my setup so really want them to be used with Cayenne, I guess what would be useful to know is does the agent part of the install do some OS specific checks which could be interpreting my OS’s as the same device somehow, that would explain why the PI 2 with the original SD worked and then the following 2 x Zeros failed, the last thing i want to do is waste anyones time here and I appreciate the speedy feedback.

The difference in the SD OS’s I have used have only been changed by using
sudo nano /etc/hostname to change their name

If anyone reading this knows if this could cause an issue it could help others as well, as when you have multiple PIs and how easy they can be corrupted I know the SD cloning is used my a number of people as it takes a while to build an OS and add all the extras you want :slight_smile:

Well, good news is your Pi 2 and Pi 3 are working.

By the way, did you see this post?


i will check that out, thanks


Hi all I just wanted to update anyone following this on what the actual solution was to my issue, I wanted to have one last attempt at loading the agent on to a PI Zero before a complete OS rebuild, Here are the steps I ran through

  1. Generate the unique install command by adding a new device in the Cayenne dashboard.
  2. SSH to pi and run the wget command and then the shell script command as shown in the dashbard
  3. When it hangs or appears to stop at the installing the agent side do the following
  4. Press return a number of times, even though it was not prompting for an input it seems this forces it to the next step, this then will continue and allow the install to continue,

In conclusion I wonder if the PI Zero behaves somehow differently than a PI2 or 3 at this step of the install. once finished after it has rebooted refresh the dashboard and you should now see the new PI showing all its CPU / Memory etc and in a connected state. Hope that helps anyone running into the same issue.

Welcome to the Cayenne community!

I have not had the same experience as you with my Zero’s. My experience has always been that the install completes without any intervention.

My Zero’s are all blind (Ver 1, no camera)
I do start with new clean OS’s
Download latest Raspbian image from raspberrypi.org
Format SD with SDFormatter
Image SD with Win32 Disk Imager
Expand disk (current Jessie versions do this automatically)
Install Cayenne via SSH command line


1 Like

Thanks for the welcome Ian and the reply, I had this happen on a version 1 and 2 of the Zero, and I guess if anyone else gets a stuck install my post may help, Now I can really get started adding my electronics to be shown on the dashboard :slight_smile:

Thank you for sharing your experiences! This is how us users help our friends at Cayenne fine tune the platform.


Back in the alpha I also thought hitting enter forced some things to happen, but in reality I was using an original Pi and it’s just a lot slower than the Pi2 and Pi3. The Zero doesn’t have the processing power the regular Pi’s have so it may just take a while longer to finish the install. I had a look at the install script a while back and there is no user input that I could see (at least at that time). Maybe @eptak can confirm if there may be something hung up waiting for input.

I left my Zero running at least an hour twice, and it never finished, its only when i clicked return a couple of times it finished the process, so not sure why

Thanks for sharing your workaround @elliot5555…we’ll investigate this!


I just had this issue on a new Pi Zero V1.3 with a clean install of Jessie-Lite downloaded today. I found that doing an apt-get update then apt-get upgrade a load of Python updates installed and the Cayenne install (run via SSH using the commands copied from the ‘add device’ dialog) then completed fine.