RPi 3 B + Stretch Lite 4.9.56-v7+ = Missing Development Headers

Hi everyone !

  • RPi 3 Model B
    Raspbian (STRETCH LITE) 4.9.56-v7+ #1044 SMP Fri Oct 13 15:23:13 BST 2017 armv7l GNU/Linux
    FW : Oct 11 2017 23:27:47

  • Web & iOS

  • Install failed using the bash_rpi… script at the “Software Components” step because of this error : “Cannot install for Python 3.5.3 : missing development headers\n”.
    I tried using the iOS app but it blocks for hours at “Installing software…”.

Can you help a new highly motivated user :slight_smile: ?

Best regards

Hi @snowpunk,

Hmmm, weird. @rsiegel or @adam , any ideas?

I have not tested new agent Cayenne install on Stretch Lite yet…


I haven’t tried Stretch Lite yet (had no issues with regular Stretch). In the past when we saw these missing development headers messages, these commands (if a bit overkill) were enough to overcome it.

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install python3.4
sudo apt-get -f install

I’d start there, and if that’s not sufficient maybe try sudo apt-get install python3.5 and sudo apt-get -f install again since it looks like its trying to use Python 3.5 on your machine.

I’ll try a clean install of Stretch Lite soon and see if I encounter any issues there.


Bit of an update here, hopefully can save you some trouble.

I tried Stretch Lite, and despite the commands I’ve posted above our agent install still fails in the same place. I have a feeling there is something we can run here to work around it since it works OK on full Stretch without any updating, and in both cases Python 3.5.3 is detected by our installer.

tagging @jburhenn as he may have an opinion on what you can run here that I’m not considering, or whether we might need an update to our install process.

1 Like

You can try installing development headers with:

sudo apt-get install python3-dev

Perhaps Stretch Lite doesn’t have those installed by default.


Let us know how that works @snowpunk.


It worked !


Thank you all…


Thanks for updating, this worked for me as well.

Thanks!! It worked for me :+1: