Rpi 3 offline, others online, still sends triggers

Hi, I’ve got a Rpi3 that occasionally/randomly goes off and comes back online. Thing drops so often that I had to turn off the “goes offline” trigger. I still get alerts though. For example: This is connected to the output of a water alarm and I was testing it to monitor a water sensor. When I test the sensor (dunk in water) I still get a triggered alert (text message) even when it shows as offline. I dont think its connectivity on my end as the alerts go through, and the other pi sitting next to it will show online when this one is off, although they dont sync up (one on, other off, or both on both off) it seems “random”

Its a Pi3 running debian 8. It comes back online if I leave it. It’ll just go away and come back, now that I know the alerts are working I am a little more comfortable using it for something mission critical, but still, having it online all the time would be cool too.


Same issue with me.

I am new to Cayenne so would like to know what will fix this.


I believe @rsiegel commented on this being due to a server issue they are aware of, but perhaps he could comment on progress

Thanks for tagging me @shovelheadman, some internal priorities have cut down on my immediate time on the forum compared to what I was able to do in the past. Rest assured I’m still here! :slight_smile:

@sensei2marc, @josh.nichols978 – the issue with determining if the devices are online or offline are on our server side, so don’t burn yourself out too badly trying to troubleshoot it or worrying about the network on your end. Especially in the case where 2 devices on the same network are reporting differently.

I just got out of a meeting on this topic – to keep it concise we’re ultimately going to be migrating from the legacy servers that have this intermittent issue to a newer technology that will be able to avoid this. In the meantime we’ll continue to monitor our current servers so they can be more quickly corrected when this issue appears.

Hi rsiegel

Non - urgent issue but appears that I cannot log in to my community user account- says there is a problem with my account and to contact the administrator? Not sure who that is…appears to have coincided with iOS upgrade but not quite sure if that caused it

Generally when I’ve seen that it was a single-sign issue (our forum and Cayenne site share a login token). Try logging out of your account at cayenne.mydevices.com, then re-logging in there, then clicking “Login” on the forum again (if it doesn’t just automatically log you in the next time you visit it). If that still doesn’t work, try clearing your browser cache/cookies and trying the same.