Bug Filed on 03-14-2016: Alerts Sporadic / not working down under

1. What OS? (Wheezy or Jessie)


2. What class/size SD card? (ex. class 10 16gb)

8db okay ----------

3. What Model Pi? (A+, A, B+, B, Pi2)

B and B+

4. Please describe the bug / issue. Attaching any relevant screenshots would be very helpful! Thanks in advance.

No alert messages:
These I have been into and out of a few times and made sure enables but simple GPIO25 ‘= Hi’ are not seding e-mail (gmail) or txt message.

Is SMS for USA only ?

Twice I have had bursts of sms txt up to several days later and only one e-mail

Reporting of ‘Ran x Times’ does not follow the number of times the pin has been activated and seen on screen.

~ Andrew

Hey Andrew,

What is your ‘digitalsensor’ that’s being used in the trigger/alert?


Generic GPIO input.
I have just strapped GPIO 24 as an OP directly to GPIO 25 IP to test this setup remotely and use it for demonstration of Cayenne on courses and tutorials I take.
~ Andrew

Additional comment…
Top RH Drop down gives Schedhule and Trigger for IP and for OP: Suggest Triggers (only ?) for IP = Input Devices and neatly complimentary Scheduling of OP = Output devices only ?
~ Andrew

Still no e-mails or sms txt alerts but tried the scheduler out and this works Great ! This kind of proves that the telecoms and e-mail Link is valid.
~ Andrew

I’ll need to spend some time investigating this…hope to respond early next week with an update here. Thanks for attaching the pic. And glad you like the Scheduler!


I will just do some restarts and try triggering from an external event (rather than simultaneous off same Pi) I may get one Pi OP triggering an IP pin on the other one :slight_smile:
~ Andrew

Hey Andrew,

Has this improved?


Tested with max memory and it filled my e-mail up.
Suggest some method of limiting the rate or making it ‘one shot’ alert ?
I will test the DO triggering a DI to confirm all is good.
~ Andrew

1 Like

I like the idea of a one-shot alert…added this to roadmap to be designed and implemented at some point. As always, thanks for your good input Andrew!

P.S. resolved this issue.