Rpi - installation troubles with Raspian


I tried to install Cayenne on my rpi - the first time, the rpi did reboot (I know this because I lost my SSH connection), then it just “hung” while I viewed the step 3 page (it was hanging on the “Libraries” part of the installation).

I deleted the Cayenne files, and tried to do a fresh install, and now I’m getting:

pi@raspberrypi2 ~/Cayenne $ sudo sh rpi_juyk1qqium.sh -v
rpi_juyk1qqium.sh: 6: rpi_juyk1qqium.sh: Bad substitution
dir exists
grep: /etc/myDevices/AppSettings.ini: No such file or directory
Invite code does not exist but directory does so we will add invite code
rpi_juyk1qqium.sh: 14: rpi_juyk1qqium.sh: cannot open /etc/myDevices/AppSettings.ini: No such file
rpi_juyk1qqium.sh: 15: rpi_juyk1qqium.sh: cannot open /etc/myDevices/AppSettings.ini: No such file
rpi_juyk1qqium.sh: 16: rpi_juyk1qqium.sh: cannot open /etc/myDevices/AppSettings.ini: No such file
myDevices: unrecognized service

I am having the same problem

@gtg254k @mechengineer2 what OS do you have on the Pi prior to installing Cayenne?


Regular Raspbian

Yep, so for Raspberry Pi, must use Jessie or Jessie Lite on SD Card.


I have Jessie installed


Oh, I hope this story has a happy ending! :slight_smile:

Would having plain Raspbian (ie. not Jessie) be an explanation for RAM/CPU/disk values not appearing on dashboard? (CPU temperature and network speed appear BTW).


@gtg254k @mechengineer2

I’m thinking that perhaps running our uninstall scripts would be in order to make sure you’re not in a weird state following attempting to delete the app manually. Do do this:

sudo /etc/myDevices/uninstall/./uninstall.sh


sudo /etc/webiopi/uninstall/./uninstall.sh

Then I would go back to the Cayenne Web Dashboard and grab the commands to re-install from ‘option 2’ of the device adding process (just in case the invite codes linked to your previous attempts are expired/invalid).

If you’re still stuck after that, let me know.


Could you post your output from cat /etc/os-release so I can see your specific OS version?

Hi rsiegel, thanks for the reply. :slight_smile:

I managed to brick the Pi during an interrupted OS update, so had to reformat the SD etc.

So now I have latest version of Raspbian Jessie with Pixel version 23rd September 2016, Kernel 4.4. (Haven’t installed Cayenne again yet though).

At the risk of going slightly off topic, but still related to installation, I have some time dependent programs which might get upset if there is lots of processor/io/interrupt usage going on.
Also the Pi is running an Apache webserver - so there can be a lot going on already!

So, how much space and network overhead does Cayenne impose on the Rpi? Sorry, I can’t seem to find any clear information about this?

Many thanks,

The used network traffic of cayenne is vanishingly small compared with the maximum possible network traffic or compared with other applications. About the space on disc, i didnt had a look right now. But also here i think that the cayenne systems takes not more then 100 MB.

Yeah, the Cayenne Pi agent install is right around 50MB. You can check the usage in /etc/myDevices and /etc/webiopi on your own Pi to make sure it looks the same.

Network use should indeed be negligible, but will depend on what you’re doing with the Pi. You’d probably have to have a whole mess of rapidly updating sensors, or constantly using Remote Access (the graphical desktop connection) to really use a lot.

As an example, we have a Demo Pi that has been up for 30 days now. It has a lot of sensors and we use it often. It’s averaging about 1 megabyte per hour in data transfer, so nothing really.

by the way, with everyone who has mentioned install troubles either silent or confirmed up and running now, I’m going to move this thread to ‘Resolved’. Go ahead and post here if you still are, of course. If you’re a new person reading this, I encourage you to make a new thread if you have Pi install trouble.

1 Like


Thanks for looking at this. :slight_smile:

Ok, finally some time to spare to look at the RPi again.

Ran the cayenne link .sh script but nothing was changing on the dashboard, so deleted the device, and installed again by running the new link and .sh file.

Still does not show memory etc., but apparently shows statis CPU temperature 40.09, and static network activity of 0.27. It shows my DS18B20 but no readings. Also no readings on RAM, Processor, Storage, and cannot perform remote commands.

/etc/os-release is shown below (Cayenne dashboard settings does not mention jessie BTW):
PRETTY_Name=“Raspbian GNU/Linux 8 (jessie)”
NAME=“Raspbian GNU/Linux”
VERSION=“8 (jessie)”

What is it best to do?


Look for a message from me in your private message inbox, there is something I want to check with you there.