RPi model B stuck on installing software

Device & model: Pi 1 Model B
Dashboard: Android
Installation is stuck on “Installing software”
There were no errors or updates, had to pull the plug and restart but same happened, waited for 3hrs before stopping again

Hey @chinmay.63, welcome to the Cayenne Community.

Apologies for the trouble you’ve run into here. Let’s try an install from the web dashboard via SSH rather than the Android app. It may still fail, but it will provide valuable error output that you can post here so we can see what the trouble is and suggest troubleshooting steps. And maybe it will just work :slight_smile:

To do this, first lets uninstall in case there is a partial or incomplete install of the Pi Agent on your Raspberry Pi. Run these two commands:

sudo /etc/myDevices/uninstall/./uninstall.sh
sudo /etc/webiopi/uninstall/./uninstall.sh

Next, run these 5 commands to update your Jessie OS, which generally solve most install issues. If you get prompted, answer yes to any yes/no prompts.

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install python3.4
sudo apt-get -f install

Now you can attempt a new installation. Please do this from the Web Dashboard. After logging in, choose to add a new Pi, and when presented with two options, select Option 2 where it shows two commands to install the software on your pi.

This way, if the installation still fails, you’ll be able to copy/paste the output from your Raspberry Pi terminal to include with your response.

Please let me know if you have any trouble with these steps or questions.

Hi rsiegel,
The issue is solved, I was using raspbian jesse lite, found somewhere on forum that lite should not be used.
I switched to full version which has solved the issue, I have not tried your solution.
The installation guide should mention that lite should not be used, can you please update it?

If you use the commands above it should work.

Yeah, as Adam said, Jessie Lite should be fully supported. It may have been the act of doing a fresh OS install that resolved it rather than the move from Lite to full Jessie.

That said, there could of course be issues, so we’ll continue to test against Jessie Lite.