Installation stops on Software Components

Hi, I am an old time user but I had to reformat the wholw project and start from 0 so I loaded a fresh Raspbian Jessie nd started from scratch.

I tried Windows SSH, Android and iOS and it always happens the same, it gets stuck on Software Components. I left it all night and it’s still there so it’s not a matter of taking 10 or 30 minutes. Any idea ?

The SSH shell stops with the following message: Build for Python 3.4.2 failed\n

I am using Raspberry Model B

Thanks for your help and regards

Which version of Jessie you are running? :slight_smile:

Sounds like the Jessie Lite install problem. Run these commands:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install python3.4
sudo apt-get -f install

I am using Jessie Lite downloaded yesterday from the site. Thanks for helping

OK, ah already done the Uodate & Upgrade (2 first lines) but not the others.

I’ll try and get back here.

Thanks for helping

I tried twice, with SSH and with iOS after doing the updates/upgrades and installing Python and it gets stuck in step 3 of 4, Installing software.

Any ideas ?

Thanks for helping

Is it still stopping on the same error message when you run the install via SSH?

“Build for Python 3.4.2 failed\n”

When running SSH I have a doubt. A soon as I chose the Rasp, it appears the 2 commands to execute in SSH but, immediatly it starts with Step 1 without waiting for the command to be given in SSH. Shouldn’t it wait for the command ? If not, what is the purpose of the 2 command lines ?

Thank you

The first command is a wget command which downloads the installer to the directory that you run it on on your Pi. The second command actually runs the installation.

I understand but I really don’t type anything on the SSH windows, it starts for itself. Is this so ?

Is it possible you are pasting them both together? They should each be run individually:



sudo bash -v

If not and I am misunderstanding what is happening, could you copy/paste or attach a file with the output from each of these commands on your SSH command line? I should be able to see what is going on in that case.

OK, what’s happening is that I see the commands but if jumps to the next page on the web ans starts step 1 and 2. I can go back on the webpage and copy both commands and execute them separately but, as the system is already executing, as this so ?

With iOS or Android I don’t see the commands either, it just start step 1 until it get’s stuck on step 3.

Despite it’s starts automatically, should I also insert the commands in the SSH window ? I did that and it executes well but it also gets stuck on step 3.

I see now that, even though the Rasp is not connected and powered, the web installation jumps to Step 3 giving the idea that steps 1 & 2 are done. And the rasp is not even connected.

So, I stopped the web installation and inserted both commands:

sudo bash -v

and the result was:

Tue 28 Mar 07:06:46 UTC 2017 Build for Python 3.4.2 failed\n

even though I has already installed Python as per the instructions in this page.

So I am lost here.


Hi @neiva.rogerio, this helps, sorry for the trouble with it.

The reason I wanted the install via SSH (rather than iOS or Android) was because this way we could see error messages in the Pi installation process. The iOS and Android apps are great, but they don’t have a way to convey this detailed error messaging.

Tue 28 Mar 07:06:46 UTC 2017 Build for Python 3.4.2 failed\n

Is a fairly common error message that we’ve seen on some installs. Try the following 5 commands, one at a time, to resolve it. If prompted with any yes/no prompts, you can always answer “y” or “yes”:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install python3.4
sudo apt-get -f install

After you’ve run all 5, give the command-line (SSH) install another shot. Hopefully it will finish OK this time (in which case it would reboot the Pi and then appear on your Cayenne web dashboard). If it does not, let me know what the result is from the SSH prompt, same as you did before.

Thanks for your patience, we’ll get through this :slight_smile:

No luck. This is what i Just got:

Tue 28 Mar 22:27:37 UTC 2017 Installing myDevices agent
Tue 28 Mar 22:32:47 UTC 2017 Found Python 3.4.2…
Tue 28 Mar 22:32:47 UTC 2017 Copying agent libraries
Tue 28 Mar 22:33:05 UTC 2017 Installing python utils
Tue 28 Mar 22:33:16 UTC 2017 Installing software components
Tue 28 Mar 22:33:17 UTC 2017 Trying to install myDevices for python3 version: Python 3.4.2
Tue 28 Mar 22:33:18 UTC 2017 Build for Python 3.4.2 failed\n

It still aborts on Python installation.

The other day I installed Python with this command and it went well:

sudo apt-get install python2.7-dev python-dev python-pip

Should I try it ?


I don’t think that 2.7 version of Python is what our installer is looking for. I have run into a few people who had to run through those commands a 2nd time, basically until it shows something like “0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.”

Do you mind running though those 5 commands once more, and just taking the entire output of your terminal, and pasting it here (or into a text file – you can attach files to posts here). It’s OK if it is very long, I know what to skim for. I’m hoping this will show the whole picture so I can see if there is anything else going on and give you further steps if it still doesn’t install after the 2nd run through those 5 commands.

OK, it’s 12 in the evening here in Portugal, I’ll do it tomorrow morning.

Thanks, I will run everything again from a clean Raspbian installation, copy the whole output into a file and attach it here but in 2 of these commands I got the 0 upgrade, etc. message.


OK, I’m back.

Cayenne.txt (15.1 KB)

Here is the file you asked for. Hopefuly you can see what’s wrong and where.

Thanks for the help.


Hi, did you have the chanche to sse what might be wrong ?

Thank you

What about use the command: sudo apt-get install python3

If that doesn’t work, you may want to read through this thread for some additional troubleshooting options: Raspberry Pi Zero installation

I know you’re not on a Pi Zero but I don’t think that matters, this has been seen when installing on Jessie Lite in the past. In my case it always resolves after running those 5 commands I’ve shared until every step shows nothing further to install (and I mean every step, your current logs still show 8 upgraded when you ran the upgrade command.)

I don’t understand apt-get well enough to know why it does that – perhaps some update needs to be in place before it can see even more updates – I know Windows Update behaves in this way.

If that (or @ognqn.chikov’s suggestion) doesn’t do it, you may want to try installing on a Full Jessie image. It can still be pared down after the fact if your concern is running a leaner OS on your Pi.