Running Cayenne on Asus Tinker Board

I have an Asus Tinker Board and I am trying to get Cayenne to run on it. It’s similar to the Raspberry Pi. Here’s a link to it.

When setting it up you have to specify it’s IP address using the phone app. It get to installing software and hangs at that point. I tried installing from a terminal window and basically same thing. It does mention something along the line of problem installing for Python 3.5.3 : missing development headers\n.

If anyone has any ideas let me know. Much appreciated! :smile:


If you’re getting errors about python try these commands that fix the Pi Zero

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install python3.4
sudo apt-get -f install

Thanks I’ll give that a shot this evening. I did the update and upgrade but only went that far. Good to know on the Pi Zero. I have one too and will likely get to setting up cayenne on it as well.



Hi Tim, I think I just emailed you in a different context about the same issue.
This thread answers my question. :slight_smile:

If the above doesn’t work for you, I would consider adding your device to Cayenne using the Cayenne MQTT Python library instead of the Raspberry Pi agent. The former has the advantage of being designed for flexible platform use instead of the more purpose built Pi agent. In addition, the MQTT option is a lot more extensible than the Pi agent when it comes to adding officially unsupported sensors and actuators.

Hi Rob,

I got your email. Thanks for responding. Yes, I was adding it as a Raspberry Pi. I will try the BYOT/MQTT method. As well as Adam’s suggestion too and see if one way or the other it works. I will post back here what happens.



1 Like

I know @jburhenn has become somewhat familiar with the Tinker Board… If you have anything to share here @jburhenn feel free!


If the steps the others mentioned above don’t work, the “Python 3.5.3 : missing development headers” error sounds like you may need to install development headers:

sudo apt-get install python3-dev

Or if that doesn’t fix the issue, possibly:

sudo apt-get install python3.5-dev

If you are comfortable using git, we have some code for the Tinker Board in progress in a branch on the public Cayenne-Agent repo here:

That’s not fully tested and must be installed and launched manually but you can try that if you would like. It should support most of the Pi functionality, except for 1-wire devices, which the Tinker Board does not currently support.

Otherwise, like Rob mentioned, the BYOT method is the most flexible so that might be a better option if you have difficulties with the Cayenne-Agent code.


I would install the API stuff here first.

Then, write some code to toggle and read I/O.

After that, as @rsiegel mentioned, it’s just a matter of integrating with the Cayenne MQTT Python library from GitHub - myDevicesIoT/Cayenne-MQTT-Python: Python Library for Cayenne MQTT API.

Check my Anova project for an easy 2 way MQTT example. Connecting the Anova Precision Cooker to Cayenne

I don’t own a Tinkerboard, or I’d do a tutorial. Maybe when you get this working, you will?



Just wanted to touch base back with everyone. So far after having tried everyone’s suggestions and then some, I haven’t had any success. I appreciates everyones efforts and suggestions. I think I am going to let this one sit on the shelf a bit for now until there is official support or the Tinker Board gains some more popularity in the community and maybe some others have some luck.