Triggers not working + MCP3204 issue


RaspberryPi 3
Jessie full on class 10 16 GB
Using the web
I am trying to use the value of an analogue sensors connected via MCP3204 Analogue converter to switch on/off relays.

ex. if soil moisture drops below 0.2 then switch on sprinkler relay.

Also in addition to this I have noticed that every time on reboot/poweroff the widgets I have set for the analogue sensors connected to the MCP3204 are not showing any values. In the settings everything is the same as it was prior to the reboot. When I change input channels manually, and then revert back to the original channel it goes back to normal and the values are being displayed again. This is also losing all previous data from the analog sensors.


Hi @hypomicro and welcome to the Cayenne Community!

Could you take a screenshot of the widgets not showing any values, and one of the settings page for each of them while it is not displaying a value? I’d like to see the state of their setting while they are misbehaving.

I don’t have an MCP3204 on hand to try to replicate this exactly, it is possible that it’s an issue with our implementation of that chip as well. I’ll get one on order.

About the triggers, is it all triggers that don’t work for you, or just ones tied to these MCP3204-connected widgets? For example, if you set up a trigger to notify you via email when the Pi offline, then reboot it, do you get the notification email?


I am most concerned regarding the triggers not working for the intended projects :confused:
It does not work after rebooting too. I cant’t remember if I tried setting the notifications mostly was trying to make it work with device switching.

I quickly swapped a new MCP3204 same results happen. Connections and wiring is all solid so that would be least concerning to cause anything.

I have captured the non-working and the working state of the widgets in 2 screenshots dislaying the widgets in the background of the settings boxes.

This happens no matter what type I insert my sensors like: Graph, Gauge, Value…

The triggers wont work in other cases too. I have tried also with the 18s20 sensor to trigger a relay.


Thanks, I just wanted to verify if triggers were working at all in your case, or if it might be related to the MCP3204 sensor data clearing. It sounds like they aren’t working for you across the board.

I also wanted to see if the widget settings had all of their fields when they were in the empty state, since this is an indication of corrupt widgets that we’ve seen in some circumstances.

Do you mind sharing your account info via private message so I can investigate with our development team what might be going on on your account specifically? We won’t click on / activate any widgets tied to real world actuators in our test. You can PM me by clicking on my name on this post, then the blue message button, and you can change the password to something you are comfortable sharing with this form:


Sure, PM sent.


Thanks for the account info. I’m able to log in OK, but it looks like the Pi is offline currently. When you have a moment, could you check its internet connection and bring it back online so we can run a few tests?


Yes, sorry about that, The Pi was powered off, It is on now.