Trouble install my devices on Rpi mod b

Download to my Rpi mod b and have no clue after many attempts at installing. Tried running on terminal but says no permission. Not a super user. I’m a little thick sometimes so a step by step will help.

Did you try to run with sudo? By default the pi account is limited so you have to run the installer as root.


I didn’t know you had to type in the address and command in terminal. Watched the YouTube video and it cleared it up for me. Haven’t checked back yet because it was taking so long to load.

Montgomery’s Repair/Santos Solar
848 Savage Rd.
Charleston, SC. 29414-5651

I am running raspbian Jessie on Rpi 2 mod b and when I run the sudo bash it stops at 0% after + exec.if i press enter then it will continue on. I am not finding cayenne on the Rpi dashboard.

You should have the Cayenne dashboard by simply going to the
- Cayenne page.

The REMOTE Cayenne is loaded onto the Rpi by cutting and pasting a UNIQUE file that is delivered to you when you add a Rpi device on the HTML Cayenne dashboard.



sudo bash -v
(YOUR rpi_*.sh filename will be unique)

which should run and load all its dependencies as per explicit instructions.
Make sure your Rpi is online (silly thought)

It almost sounds like your file
was either NOT downloaded properly,
or downloaded to the wrong file folder,
or just scrogged…

I would suggest a fresh OS install on the RPi, and try again.
It should be VERY cut-and-dried.

It’s used to install cayenne on the Rpi dashboard. I want to connect my Rpi to a 12" touch screen and have local control of my cayenne dashboard.

Montgomery’s Repair/Santos Solar
848 Savage Rd.
Charleston, SC. 29414-5651

I see the misunderstanding here-
wget FILE
is NOT used to place a Cayenne desktop on the RPi, (that I know of)

The wget file
is used to load the REMOTE RPi Cayenne background files.

To load the Cayenne “dashboad” onto the RPi, just use your browser.
(I don’t know of a dedicated RPi Cayenne Dashboard app)

I would prefer some TABLET device running the Cayenne Desktop APP,
but…to each his own.

Hey, @bestes , clarification?

After my brain failed me on coding ide on my mega, I thought Rpi had features I really liked that made it simpler. Then finding Cayenne was a god send because it fit exactly what I was doing with my solar power project overseas.

I may have misinterpreted what the video was implying. Running the iOS tablet version certainly does install all necessary files to the Rpi. But, a desktop app on the Rpi would be right up my alley.

That is an excellent suggestion.
also, the Pi APP should have Local SERVER functionality for Cayenne.
I’m not sure I fully trust Cayennes’ servers.
Things fail…
and if I lost connectivity, I could be:
locking myself out of my house, my safe, my garage door, my remote gate…
losing control of my lighting
-general disaster.

I strongly prefer a LOCAL Cayenne server. Pi3 would make a nice platform.

Locked myself out after hurricane Matthew. Left the key fob inside and had to hunt up the key for the z-wave schlage deadbolt. iOS app was having trouble with the server as well so it wasn’t any help either.

wget is simply a command to download something. In this case it downloads the Cayenne install script.

Unfortunately most of the browsers are a bit stripped down and don’t completely work with all the Cayenne features. It looks like hv3 is the best supported browser as of a month ago Remote Access & Web Browser - #9 by rsiegel

These are all perfect examples of why you need to build in a backup to critical systems reliant on power :wink:

The new version of raspbian Jessie has Chrome as web browser and does load much faster, but when I load the new Rasbian I lose my Cayenne project,_ so that’s the next puzzle to figure.

Montgomery’s Repair/Santos Solar
848 Savage Rd.
Charleston, SC. 29414-5651