Problems installing Cayenne directly on Pi


I’m using Raspbian Jesse on a Pi2.

I’m trying to install Cayenne directly onto the Pi using the local terminal window as detailed in Cayenne Documentation

When I enter “wget” (no quotes) into the terminal window I get an “ERROR 404: Not Found”

I’ve tried this several times with the same result (BTW it would be helpful if you provided the installation link in the tutorial as text to cut and paste rather than just as an image)

The link to the video tutorial at
fails with “The page you requested doesn’t exist or is private.”

I’ve plenty of experience with Windows but little with Linux (and don’t have access to IOS devices) so I may be doing something dumb.

#2 is just an example install script in the guide. You will need to follow the instructions in the guide and use the URL that is generated for your account.


The text you typed into the terminal was just example text used in the tutorial. Once you sign into your account at you’ll be given your unique code that you will type into the terminal and begin your download. Let us know if you continue having trouble here! Thanks and welcome to the Cayenne community!



Thank you for the swift response and the welcome!

Following your helpful guidance I logged in to my account and carried out the installation (may I suggest amending the Cayenne Documentation page by adding a link to the signup page?) .

Unfortunately the process stalls at “Installing myDevices agent”

I have used sudo raspi-config /Expand Filesystem which reports (correctly) that the installation was done through NOOBS and that the Filesystem is thus already expanded.

df -h gives me:

Filesystem Size Used Avail Use% Mounted on

/dev/root 29G 4.2G 23G 16% /
devtmpfs 459M 0 459M 0% /dev
tmpfs 463M 0 463M 0% /dev/shm
tmpfs 463M 6.3M 457M 2% /run
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 463M 0 463M 0% /sys/fs/cgroup
/dev/mmcblk0p6 63M 20M 44M 31% /boot
tmpfs 93M 8.0K 93M 1% /run/user/1000
/dev/mmcblk0p8 488M 408K 452M 1% /media/pi/data
/dev/mmcblk0p5 30M 1.6M 27M 6% /media/pi/SETTINGS

As previously mentioned I’m using the full version of Raspbian Jesse on a Pi2


Can you provide any assistance with the installation issues described above?


Hi Charles,

Hmm, sorry about this. Do you think you can PM your login credentials to Cayenne?



Hi all
I’ve been experiencing some problems my self is there a path were we can get are URL number ?



Welcome to the Cayenne community!

Can I recommend that you start a new thread for your difficulties since this one has been marked ‘Helped’.
Also if you could provide some more information as to where you are trying to install from, (windows, mac, android, iOS, raspian or other) and a little about your raspberry ( a, 2b, 3b, zero, or other) and how it is connected to the 'net (WiFi, cabled) that will help the community with helping you attain your goals in discovering all that makes Cayenne wonderful.

You might find the answer you need here - Getting Started

Again welcome, looking forward to your response,