Trying to login jumps to get started

Hi all, Been using Cayenne for 3 projects so far but hadn’t had this problem before.
Project: Keggerator
Device: Raspberry Pi3, 3 DS18B20’s, 2 Relays and a 7" monitor.

This project has been running now for awhile with no issues. Today I did a shutdown and removed power. applied power, and rebooted. On other computers (PC and Android) dashboard came up fine after login. But on the Pi (Raspbian with Chromium) when I tried to login and filled in the fields it jumped over to the getting started page that shows the App links.
I tried:
Rebooting, did a Raspbian update, clear chromium history. Stays the same. The Cayenne program is running fine, I see it on the other computers. The only thing I did during the shutdown was mount the Pi in a case behind the monitor. Internet is accessible from it.

Any ideas before I resort to doing a reinstall?

Hi @nybuzznm,

Was it working fine on Raspbian Chromium before you did the shutdown?


Yes. This is the only web browser installed.

This may be because Raspbian internet browser does not support some functions of the Cayenne dashboard. In past, I’ve seen issues when people have used the Raspbian browser. I suspect this is the case since it works fine on Android and PC browsers as you said.

Is there reason why you must use the Raspbian internet browser?


Just installed Midori - Went to login and it said “oops! something went wrong!”
Next installed qupzilla - Same exact results as with Chromium.

My guess here is that this isn’t related to the Pi browser at all, but that the browser window is too small horizontally. The way our site is designed, if the browser isn’t wide enough (I want to say 800 pixels or so), then it will assume it is a mobile device, and collapse down to 2 App Store buttons, because it doesn’t have enough horizontal space to display our web UI.

You can see this yourself on any computer just by making the browser window small. I’d try maximizing it and seeing if that resolves your issue.

Why would it bounce by itself to the get started page?
. I know, odd.
BTW - It’s a 7" 1080p HDMI E-bay China car monitor. Did work with Pi/Cayenne prior.
Since rsiegel mention this, I am wondering if the monitor changed its resolution - but that wouldn’t explain the page just without the opportunity to login

Is this the page you’re seeing?

If so it’s definitely the website assuming it is on a mobile device browser and trying to directly you to use the native mobile apps instead. Maximizing the browser should work so long as your display is not set to a very low resolution.

Ahhhh!! We got a winner!
I went into the Pi preferences page and scrolled down to a 1024 display choice then applied it. awesome! I just can’t help to wonder why it changed.
Hats off to ya RSiegel, I guess I owe you a beer from this 6 tap commercial bar back keggerator that my wonderful wife allows me to have in the house.
Also, Thanks to Bestes - been awhile since I pinged in.

1 Like

If you have any hoppy IPAs I might just take you up on that :yum: