Unable to view Temperature data in dashboard


#1

Hi,

DevEUI is 1234567898765432.

Using ACSIP S76S EVB, TTN server.
using the standard Cayenne data format to send the data, 0167FFD7, sending manual data without actual sensor for 15sec to 20Sec, only for test.

I can see correct data on TTN and displays Temperature at TTN, but i cannot see temperature data on Cayenne, only RSSI and SNR is displayed.

image

I have earlier posted in different thread which was closed, so opened the new post.


#2

@rsiegel can probably help here when he has some free time :slight_smile:

~Benny


#3

@hvenkatesh,

Can you try sending it on another channel like say channel 5. Try 0567FFD7.

I am wondering if your RSSI or SNR is already using channel 1 and thus ignoring your data.

Cheers,

Craig


#4

Hi,
I have tried changing the Channels and different data.

i have used Cayenne LLP as Payload format in TTN and can view the data correctly.
But still i get only RSSI and SNR.


#5

Hi @hvenkatesh, thank you for your patience.

Right now the last few payloads I’ve seen from that device EUI all look like this:

BnEE0vsuAAA= (in base64) which translates to:
06 71 04 D2 FB 2E 00 00 in hex.

Using the CayenneLPP spec, we see this as:
06 == channel 6
71 == accelerometer data
04D2 == 1234 == 1.234
FB 2E == -1234 == -1.234
00 00 == 0000 == 0.00

This is decoded in our system like so:

[
    {
        "channel": 6,
        "type": "accel",
        "unit": "g",
        "value": [
            1.234,
            -1.234,
            0
        ],
        "name": "Accelerometer (6)"
    }
]

That seems to match up with the latest items in your screenshot (after you switched from temp to accelerometer data), and I’d expect it to create an Accelerometer widget on your dashboard.

Can I ask if the Cayenne web dashboard was open at the time of these payloads being published? I know that initial widget creation needs the dashboard to be open – after that you can publish payloads and they should be recorded without needing the browser to be open to your Cayenne dashboard.


#6

Hi,
The dashboard was open for the first time data is transmitted.

I have deleted the device in Cayenne and again registered to confirm that dash board is open.

But i observe the same results, still no widget generated for either Temperature Sensor or Accelerometer.


#7

Tried registering new device on TTN and then Mydevices, no improvement.

DevEUI: 00B9F1545E281935

I hope no issue from data Side, not sure why widget is not getting created.


#8

any update?


#9

seems no one to answer, is any one else facing such issue?


#10

Hello,

I have sent (with success) the same payload (LPP accelerometer) to Cayenne from device Nemeus mk002-eu

Add Cayenne integration on TTN account

On Cayenne accout, add device as “Cayenne LPP”

Send payload from device

Payload is uplinked via TTN

Accelerometer values are shown on Cayenne account, just below the map


#11

Thank you, but not sure what is the issue with integration.

Payload reflects correctly on TTN, but no widgets formed on cayenne.