Unofficial Workaround for Jessie Lite! [EDIT: Jessie Lite now supported


1. What OS? JESSIE

2. What class/size SD card? 16gb Class 10

3. What Model Pi? Pi2

Exactly like:

However, issue has not been resolved. I couldn’t find a way to add a comment to that topic (I think it’s been marked as resolved). I am getting the same error trying to install today (Jan 28th, 2016).


When will Raspian Jessie Lite be supported?
Bug Filed on 02-25-2016: Cannot install for Python 3.4.2 : missing development headers
Bug Filed on 04-26-2016: Problem installing to rpi
Bug Filed on 02-25-2016: Install fails in Installing myDevices agent
Cannot install for python 3.4.2 [Helped: use Jessie Full]



@jaredk Were you using Jessie Lite?



I believe I was. 90% sure I was.

My micro sd card has since died on me so I can’t check atm.


Then I’m 90% sure this was the issue. We’ve had other posts come up about Jessie Lite not working, and I only just now made the connection with your experience. If you could, try again use the Jessie Full and you should be good to go. Let us know how it goes when you get around to it :slightly_smiling:



Will there be a fix to get this to run on Jessie Lite?


Yes, we’ve been seeing enough issues for Jessie Lite that warrants us to get this compatible with Cayenne. Keep you updated with more details about when we push the update for Jessie Lite. In the meantime, I would suggest running Jessie Full or Wheezy. Hope that’s okay with you.



Changing this to FAQ, adding Jessie Lite support is on the roadmap.


I’m glad to hear lite is on the roadmap! I’m hoping this will help with the PiZero, as I’ve noted, it’s working it’s little butt off trying to stay caught up.


Unofficial work around:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install python3.4
sudo apt-get -f install
sudo apt-get install python3.4
sudo apt-get update
sudo apt-get upgrade

After the script gets to 100% and the Raspberry Pi reboots go to and your dashboard should load right up.

Probably not a very elegant way of getting everything working but it worked for me.


@svazir @akaranfilian Let’s take a look at this! Thanks @jaredk


pinned globally #12


Gave this a shot on the Zero last night with the Lite version dated yesterday (2016-02-09-raspbian-jessie-lite.img), didn’t work. I’ll give it a go again tonight to see if I missed something…



I finally had a zero arrive 3 days ago. Going to put it through some testing soon as well. Keep us updated.



The second try with the RPiZero, Jessie Lite, and @jaredk unofficial work around didn’t work. Got all the way to reboot, but nothing after that. I’m having a difficult time keeping the Zero talking to the network via a dongle so it is very possible the problems are on my end.



Hi Ian,

If the script went all the way through to reboot then that means my unofficial workaround was a success! :slightly_smiling:

All you have to do now is head over to : and your dashboard should load right up.


Bug Filed on 03-01-2016: Install Fails (Fix Edit: need to expand file system)


Jared, thanks for the note! I had a feeling that was the case. The problem is no dash board reaction at all, just sits there waiting to load. I’m concerned I have wifi network problems, as of this morning the Zero with the SD card with Jessie full version on it wasn’t communicating with the Cayenne dashboard with consistancy. I need to get a USB to ethernet adapter to get the wifi variable out of the mix.

Thanks for your insight,

Bug Filed on 02-01-2016: Does anything work with this yet?

Thank you!
Using this guide I can install cayenne in my raspi jessie lite!


Great job jaredk. Just got it to work on my raspberry pi 2 with Jessie Lite.


@jaredk @Ian @cramos @jshort1008 Heads up guys, Jessie Lite is now natively supported with Cayenne.

A BIG thank you to @jaredk for posting the workaround.