24hr graph No data available

All other time inquires work.


which device are you using?

I have the same problem, it worked till some time ago, today I noted this issue.
Data have been sending to my dashboard for months so far.


Arduino Uno. It has been working for a couple of years. It’s only the 24 hr graph that does this. Same problem March 18 2020.

can you back up the history by downloading it in csv file and then delete the widget. A new green widget will appear on the next publish, add it by clicking on the + .

Shramik, Didn’t make a difference. The “no data” message still instantly appears, unlike the other time requests that take seconds to fill in. I have 15 numerical widgets and 4 graphs between 2 devices, they all do the same thing.

can you share the code.

I could Shramik, but it’s exactly the same problem as on March 18 2020. The work around using custom dates does work now as it did then. Thanks to elpados for that solution, I forgot about it.

Similar issue here, The 'D(ay) view is not working on anything on several projects, tech and OS
The Custom does work but when set for today (one date only) it gives 2 days of data.
A kind of date roll over GMT versus Local time issue ?
~ A

( 4 ambient Penguin Burrows and solar battery voltage)

“The Custom does work but when set for today (one date only) it gives 2 days of data.”
It may have something to do with your time zone? It does show 24 hrs for me. It would be nice to get it fixed again, but it took a month last time.

I have the same problem.
IOS App has worked fine for over a year (apart from your issue of day, month etc in wrong direction, reported months ago) NO CHANGES MADE.
Dashboard on laptop is same.
from last week always shows ‘no data for this period’ in day. The data is there in DATA on dashboard.

I have had the same problem for a week or more: live, minute, hour, week, and month usually work. Day has not worked for some time. Data retrieval and display has always been buggy for me and often takes multiple tries to successfully display, but the problem with the day retrieval has been consistent and ongoing.

This is in addition to the problem with data gaps that I posted about in a separate bug thread

Trend data update:
Trends still gave gaps and out of synch’d to day view as above still even in this side of date line (+13 gmt)
The custom to and from same date options gives last two days data
Hour view and minutes works okay
Day option: No data
Week view sometimes gives just a few days view
Month view: Lots of holes.
~ A

You’re not the only one. Pretty much the same results here. I just noticed Feb 5 - Feb 15 is missing, among other gaps. I’m starting to think it is what it is due to no comment by Cayenne. Free service, as is.

Yes I appreciate the generosity in Cayenne MyDevices kindly holding so much data on our behalf. The system of filtering down to day, week and month views is good, fair use and rational. I would not even mind if an even lighter more compressed option over a shorter total history was a new normal. Perhaps a ‘keep alive’ widget so some projects will naturally archive off if ‘no dashboard activity’ and or auto-pause ? We can always shelve data out of the various dump options. We can always MQTT to our own server / storage if higher res is needed. Perhaps something exciting is in the wings :wink:

Fixed Thanks +++

Still not working for me

Perhaps Reset Dashboard ?
Try setting up a new trend or viewing from a different browser / setup in case some kind of a history holding things up ?
Still okay here now, just checkd. The Week view is still building out 5 days Hx for projects here. 3 Month view is even shoing historic Jan and Dec data in patches.
~ A

Thank you - good suggestion. Resetting the dashboard yesterday did work.

I had previously removed and re-added the device which did not solve the problem. Don’t know whether removing the device and re-adding now would also work but since resetting the dashboard definitely did work I am happy.