Bug Filed on 04-06-2016: 100% cpu android device

When reporting bugs, it’s most helpful if you can include:

  • Android device info (e.g. Nexus 6P):
    LG G2

  • Raspberry Pi device info (e.g. Pi 2 w/ Raspbian Jessie version 02/26):
    B with Jessie

  • Describe the steps it took to produce the bug / issue:
    Open App

Seems like having the android app and the web dashboard both open pegs the CPU at 100% continuously. I haven’t tried just the app. It’s also erratically recording data points, I assume it’s related to CPU utilization.

This is also a bit strange, the graph show 100%, but the percentage and totals don’t add up.

And here is the output from top:

I’m not able to reproduce the 100% CPU usage. I do see the average CPU % not updating as well as it does in the Web though.

Can you paste in the output from ‘cat /proc/cpuinfo’ run from your Pi?

processor : 0
model name : ARMv6-compatible processor rev 7 (v6l)
BogoMIPS : 2.00
Features : half thumb fastmult vfp edsp java tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x0
CPU part : 0xb76
CPU revision : 7

Hardware : BCM2708
Revision : 100000e
Serial : 00000000c0d6010c

I am seeing 100% CPU utilization on my model B Pi with Android 5.1.1 on a G5 the majority of the time as well; I was curious, so I set a trigger to text me if CPU fell below 100%…it pinged me 14 times in 10 minutes.

I wonder if the gauge in the the dashboard doesn’t have some “momentum” though…texts generally reported around 47% usage, but I was seeing dips on the dash down to 7%.


A bit more to add after seeing @apophene’s post “top” and Cayenne do not agree on RPi CPU usage if Android is (or has been) connected. I’ve verified via top that the CPU is maxed out while android is connected.

Returning to normal after I kill the android connection:

In addition it’s maxed out with only android connected and not the web dashboard:

And then frees up, with nothing connected, i.e. android disconnected.

For my testing I’m rebooting the android device, an LG G2, to ensure it’s killed.

Incidentally I tired the app on an old tablet I had laying around, TF201 Transformer Prime, and got the same result. I know this android test round isn’t about tablets, but this at least makes me think it’s the pi and not the android device.

I will open an item for investigation by the team. Its curious that the high CPU users in the list is not our service. But that doesn’t mean that Cayenne isn’t triggering the system processes too much. We will investigate.

@apophene Is the Pi you’re seeing this on also a Model B Revision 1.0 as it is with @jhovak? I’m just wondering if this is a bug on specific hardware…

Yes it is; I should be able to test against a Model 2 later this week.


Mine is actually a Rev 2 based on:


@jhovak Thanks for clarifying that.

I haven’t had a chance to do any real testing, but I think the CPU usage in the newer version is at least not always at 100%.

If it helps, I installed this on a RPI B Version 1 and had the same issue. 100% CPU when Android app is connected. I installed the latest Ceyenne with the latest Jessie version on 8/23.