Bug Filed on 05-09-2016: Removing dashboard sensor for I2C MCP23008 extension is in infinite loop

What dashboard are you using? (Web, iOS, Android)

What OS? (Jessie, Wheezy)

What Model Pi?
Model 2 B

Please describe the bug / issue. Attaching any relevant screenshots would be very helpful!

I have an I2C MCP23008 for which I was setting up input sensors on the dashboard. I ran into trouble changing a sensor’s name, didn’t understand the slider for a 0/1 digital input, and on another sensor I couldn’t change the display back to “none” from “Value” which displayed “NaN”. I then attempted to remove one sensor. The sensor began displaying a revolving/removing indicator which never went away (at least 30 minutes). I then tried to reboot the RPi from Cayenne, which didn’t work. I restarted my laptop, powered the RPi off/on, signed back into mydevices.com, and found the sensor still displaying the revolving/removing indicator.

What to do? I’m just getting started in Cayenne, needing to migrate from ioBridge.


I noted that the problem is with the WEB interface only. From my Firefox browser today the Overview’s sensor display still has the revolving/removing indication, while from my Android phone all appears fine.


I had the same problem with another sensor. You should try reset on the dashboard wich worked for me.
Hope it helps.

Thanks, but on my browser window I see only reboot and shutdown. I tried rebooting yesterday but it didn’t help. Note that from my android phone there is no problem, but from my laptop I can’t even properly edit or re-position a dashboard sensor.


Regarding using the reset, I had a case of tunnel vision but now saw and tried the reset you mentioned. That took care of the removing/revolving indication, although it also erased some good dashboard sensor widgets. Along the way I also discovered that to move a widget on the dashboard (Web Browser, not mobile) I just needed to more specifically select the widget by clicking on it’s name. So, thanks again…