Bug Filed on 12-13-2015: No connection after setup

1. Is this related to iOS or the online dashboard?

Online Dashboard

2. Please describe the issue you are experiencing in as much detail so we can quickly resolve.

Ran the installation script, device was added to online dashboard, but Last known status
has not updated since then. (It’s been an hour or so)

Commands don’t do anything (Except for Rename, but I assume that’s on the dashboard only)

And then also getting a connection error when trying to add a relay widget

Reboot the Pi from the terminal? May take a minute for dashboard to register the Pi again once it comes back online.


Putty > SSH to pi works fine. Rebooted already, no change.

Removed and reran the setup > shows the device in the dashboard, but again, Last know status doesn’t update at all.

Reinstalling the OS now, and will see if there are any changes

Did you at any point do a straight unplug of the Pi? We are working on an issue where if the Pi is disconnected from power abruptly it goes into a weird state as you are describing. To fix, you need to do a straight unplug (for the second time) to put it back into correct state.


Pretty sure I did at least once yes.

Reinstall got it connected, but adding relays got a bit strange…

Relay1, added > back to dashboard > Showing no connection on widget
Relay2, added > back to dashboard > Now Relay1 is showing fine, but no icon on Relay2
Relay3, added > stuck on same page with spinning wheel on green bar,

Go back to dashboard manually, double widgets.
Try to add Relay4, same issue as Relay3.
Try to reboot from Commands, nothing.
Reboot via SSH, relays get toggled off, and on.

Back on dashboard. Looks like I’m stuck with the same no connection issue.

Last known status: 11 minutes ago (Dec 11, 2015, 20:50 pm)

Sorry about your difficulties Derik, I’m know it’s frustrating. We are working to resolve this

Question, did you have WebIOPi already installed on your Pi before installing our agent?


No worries. Some issues are to be expected in alpha stages.

I did a clean install of Debian Jessie, so no previous version of WebIOPi .

Update seems to have fixed the connection issue. Just have to refresh the dashboard every time you reboot the Pi, otherwise the widgets don’t connect/activate.

That’s good news. Still though, ideally you shouldn’t have to refresh the page every time. @svazir @lsanchis let’s create a card to look into this.

Another question. When the Pi reboots, it toggles all the gpio’s to low, so all my relays activate
on every reboot. Is there a way to change that to only some or none? Or like, a last known state?

Try editing the widget (cog wheel icon in top right of widget) and “invert logic”…I think what you are talking about is different though. We experience the same thing.

@svazir @lsanchis let’s create a card for this too.

Thanks for the feedback Derik!

Tried that already, but then the relays don’t toggle. Just get a spinning wheel until I refresh the dashboard,
and then it still remains in the same state. If I change it back, the relays toggle again.

Access after right setup was fine, but it looks like the dashboard still loses connectivity
with the pi after some time.Tried restarting via SSH as well, but made no difference this time.

Then removed from dashboard, and getting this error when I try reinstall

wget https://cayenne.mydevices.com/rpi/rpi_96kd888ucn.sh
–1970-01-01 00:03:09-- https://cayenne.mydevices.com/rpi/rpi_96kd888ucn.sh
Resolving cayenne.mydevices.com (cayenne.mydevices.com)…
Connecting to cayenne.mydevices.com (cayenne.mydevices.com)||:443… connected.
ERROR: The certificate of ‘cayenne.mydevices.com’ is not trusted.
ERROR: The certificate of ‘cayenne.mydevices.com’ is not yet activated.
The certificate has not yet been activated

@svazir Let’s look into this