Buttons after update


#1

After the update, the buttons, such as shutdown, restart, stopped working. Other buttons working through ESP8266 and Raspberry also stopped working. How to fix this problem?


#2

Can you PM me your account e-mail id


#3

Hi,

I’m having same problem. I’ve been running several devices on Cayenne for few months which monitor and control sensors and actuators (relays) on my project. It has been working near perfect (Thank you all at Cayenne!!) until the last few days and then the buttons stopped working. When you click on a button it changes to the spinning progress wheel and no longer activates my relay. The sensors appear to still be working as before. Did something change at Cayenne that requires me to make changes/updates on my end?


#4

Same issue at my site
Button don’t react anymore on my 2 systems

Even after reinstalling caynne agent on one of my systems,
After reinstall I can’t even create my actuators anymore(relay) I always get a timeout when I create them


#5

Me too


#6

I try different system old and new kernel different raspberry and stil is problem


#7

@andre1 can you PM me your account email_Id.
@yves.deschoenmaekers and @rafal.kolarz we are looking into your issue. will let you know when the issue is fixed.


#8

Hello, I’m having trouble also, the relay buttons do not work and sometimes show up as digital inputs.


#9

@adbrig4 can you PM me your account email id.


#10

Ok, sorry for the dumb question, for the PM s do I click on the username and click the message box right under the user profile?


#12

In my observation, the button problem preceded the big server upgrade.

I have some “old” devices where the buttons and sliders continue to work fine.

I also observed this constant “spinning” of a button after you clicked it, before the upgrade.

I currently have a device with this “spinning” button problem. I find that the button does work – the device receives the event of a button-press, but the web-page does not show the completed value of the button-press, just the spinning. The sliders have a similar problem, where the device receives the event of the slider change, and the slider shows the correct value on the web-page, but when you return to that web-page later, both the slider and the spinning button are greyed-out – the web-page does not know the value of the button or the slider. And when you return to the web-page (or do a browser refresh), the spinning-button has stopped and it is greyed-out, but you can click the button again to send a new event to the device.

So my guess was that the database entry for the creation of the device, or the creation of the button/slider has changed and the old device/button definition is working, but the newer device/button definition has this problem … and the problem is in the web-page display.


#13

I also had the problem since yesterday. When I press the button, it showed “Problem sending command: Sensor command failed” temporarily on the top, then the button was spinning. However, the relay was not working.


#14

We will be releasing a fix soon!


#15

@andre1 @adbrig4 @Alex_Gorr the issue with button actuator widget has been solved. can you give it a try and let us know.
@rafal.kolarz @yves.deschoenmaekers the issue while adding a button widget has been solved too. can you try and let us know.
@jameszahary and @2013atai can you test and let me know if the problem still present.


#16

Hi. Thank you for the update. Button functionality appears to be working again between the dashboard and device but a word of caution to other users that had this issue to check their virtual channel button assignments/mapping. They changed on my system when re-activated so the buttons no longer control the relays I originally programmed them to. Also, some button presses are activating other buttons which again is probably being caused by the vchannel/button assignments changes that occurred at Cayenne.

Correction/update: upon reviewing my original sketch file it appears I may have inadvertently changed the button channel assignments on my dashboard a few days ago while trying to troubleshoot my system. I now have my dashboard button assignments back to where they were before Cayenne updated their server and everything is working correctly as before.


#17

thanks for the update.


#18

My buttons still not working - that is, they work, but they keep spinning and I have to refresh the page to get them to stop so I can click it again.

I see that 1 week and 1 month graphs are working, and the 1 day is mostly back - I’m getting about 18 hours rather than the full 24 ???

Rest api still not working for me.

Back to spinning buttons here are some pictures:

  1. starting case with button and slider in upper right (greyed out)
  2. click button and it starts spinning - you see topic 7 (the button) prints out on 8266 console
  3. click slider - button still spinning, and topic 8 (the slider) prints on 8266 console
  4. click slider again - button still spinning, and topic 8 prints again on 8266 console
  5. click another device, then click back to this device - button and slider are now greyed out - they do not know their status

This is a 8266 using Mongoose which is another variable, but the interaction is still simple mqtt I think.
Also I have some buttons and sliders on another ordinary 8266 with cayenne library that worked throughout this episode.

image

image

image

image

image


#19

Thanks a lot! It is working again. Although the virtual channels buttons show up when I click the relay button just as @andre1 said. I don’t care about it very much. Thanks again for system resolving.


#20

@jameszahary is this issue specific to Esp8266 using Mongoose or affected all devices present in your account. if so then can you PM me your account email_id.


#21

A rewrote the program for regular Arduino <CayenneMQTTESP8266.h> and re-using the same device setup …

… and the button and slider would report to the device, and would persist correctly after I refreshed the webpage for the status of the button/slider.

Then I plugged in the other 8266 with the Mongoose version of the code …

… and the button and slider would report to the device, but when I refreshed the webpage for the status of the button/slider … it would revert back to the values they had when the regular Arduino 8266 was plugged in.

Step 1 - 10:53:10 slider is at 9
Step 2 - 10:53:25 move slider to 4 - msg arrives at Mongoose 8266 with slider at 4
Step 3 - 10:53:55 click off, then click back to device, and slider is back at 9, where the Arduino 8266 left it 10 minutes ago

So that is strange. Must be some feedback comes from Audruino mqtt 8266 library that does not come from the Mongoose mqtt 8266 implementation, and the Cayenne database does not record the Slider value of 4!

So you can cross this problem off your list. Thanks :grinning: