Can't remove 'dead' sensors/widgets


This happens in the web dashboard.
I call ‘dead’ sensors the sensors that are proposed when data coming from new channels are acquired for the first time.
They appear in a green box. I click on the ‘+’ button and the sensor is added to the sensor list (left panel).
The problem is that this sensor/widget is than not usable anymore. It seems dead.
And this sensor/widget seems producing also ‘Server error’ on the Android App.

It can’t be removed or more in general the properties can be exploited.

best regards,


@mvimercati try uploading a blank sketch with same credential only to connect to cayenne and try removing the widgets. don’t add any cayenne.virtualWrite.


@shramiksalgaonkar sorry I don’t understand what should I do. What do you mean with blank sketch? and with virtualWrite? Thanks for your support


which board you have used?? and what were the steps you used to connect it to cayenne?


I use a raspberry pi 3 but only with a javascript mqtt cayenne library. You can find the code here:


@mvimercati the solution i gave early was for esp8266 board.
@rsiegel @adam will know better about raspberry pi.


@shramiksalgaonkar I think it’s a pure problem of the dashboard, nothing regarding the board/device.
If I add manually the new channel everything works fine. The problem is that I can’t remove the ‘auto’ proposed sensor as I described before


@mvimercati you can remove a sensor by clicking on setting and remove option but for this the device should be online.


@shramiksalgaonkar The point is that the settings panel does not appear for this ‘dead’ sensor. Moreover I can see the sensor on the left panel, but not on the dashboard itself. Look at the screenshot, Channel 31 is the unremovable sensor.

It’s perfectly reproducible.


@mvimercati try to reproduce channel 31, add it to dashboard and then try to remove it.


@shramiksalgaonkar I’m able to add and remove another widget on channel 31, but I can’t remove the ‘dead’ one.


@rsiegel @bestes may figure what this bug is about.


@mvimercati, if you left-click the “Channel 31” entry in the left sidebar, does it open any settings dialog?

I suspect this is a mobile/web sync issue and perhaps you can try to delete it from mobile if that doesn’t produce a settings dialog?


@rsiegel no If I click on the left sidebar the settings panel is NOT opened, differently from other working sensors.
I can’t also delete it from the mobile app (android) because that sensor is not displayed in the dashboard (like it is not displayed in the web version dashboard, as you can see in the screenshot).


Hello Sir,
Please try the above operations but with different browser. I encountered the same problem when I used a special version of mozilla firefox. The render engine has some bugs.


@ognqn.chikov I tried with different versions of Firefox on Windows and Linux and also Chrome on Linux. Maybe I can try with MS Edge, but the suspect is that it’s a systematic bug of the dashboard.
I tried the browser javascript console debugger and I get this error every time I click on the ‘dead’ sensor in the left sidebar. Hope it can help.

vendor-4cd0390d50.js:290 TypeError: Cannot read property ‘basePath’ of undefined
at PanelSettingsController (app-d5a86770ca.js:3027)
at Object.invoke (vendor-4cd0390d50.js:213)
at R.instance (vendor-4cd0390d50.js:262)
at vendor-4cd0390d50.js:502
at vendor-4cd0390d50.js:303
at m.$eval (vendor-4cd0390d50.js:317)
at m.$digest (vendor-4cd0390d50.js:314)
at m.$apply (vendor-4cd0390d50.js:318)
at l (vendor-4cd0390d50.js:269)
at D (vendor-4cd0390d50.js:274)


@ognqn.chikov @rsiegel @shramiksalgaonkar I was able to delete this ‘dead’ sensor by manually sending this HTTP DELETE request:


(where d694ce80-b88f-11e7-b177-579293954599 is the sensor id I suppose).

Refreshing the dashboard the sensor disappear. A bit tricky but it worked. I can imagine this is a stupid bug on the web ui,
due to the fact the backend seems working well.


And the “Server Error” on the Android App disappear too.


Yes. this might be a bug :frowning:


great work @mvimercati. good to hear that you were able to find the solution to the bug.