Problem on power on / off


I have a raspberry 3 using with cayenne usually to do tests with a led, relays, SSR, DS18B20, etc.
Normally I have never worked through the web but since the apk of the mobile (android).
Lately I have a curious error (from the phone):

  • I press a button and immediately the device is activated and the button lights up. (Apparently all correct)
  • After a short time the device is still active but the button fools me and shows off on the screen of the phone (if it was not present would interpret that it is not active)
  • If I press the button again, it will light again (without changing the status of the device = correct) and this time if the button constantly remains on, in line with the output status of the device
  • Then I can press the button again and correctly disconnect the device and turn off the button.

All this mentioned above is repeated every time I repeat the on / off cycle on any device


maybe the application is loosing connection and going in “sleep” after some time when you leave you device with the open app? What about if you close it and open it again?


Hi @zumoceba,

I’m a little unclear if you’re seeing this error only in the Android app, only on the web, or on some combination of the two? It sounds like just on the phone? So you press a button widget on the phone to turn to ON state, and it is turning back to OFF state on the phone after a short time?


Forgive the delay in answering.

The problem was solved by restarting the router (I have the raspberry 3 connected by wifi).
Answering, for the reason that is through the web does not answer the application, everything I do with the mobile with android.
Another issue that occurs to me although I understand why I have a pin defined as input through a button, the recognition of such a pulse is extremely slow (I guess it must transmit to the server and respond) so much that it does not make it viable The time of practice.
Could you find a solution to this problem?


Glad to hear at least that the initial problem was resolved.

You’re correct, any communication between a Cayenne widget and a Pi on your home network is going through our cloud server, so that will introduce some latency, but it shouldn’t be that much at all. I just ran a test with cell phone on cell internet --> Cayenne cloud server --> home router --> WiFi --> device to turn on and off an LED (basically the slowest test I could think of) and it was still less than a second to blink the LED.

What sorts of round trip times are you seeing? Does it improve at all if you connect the Pi by wired Ethernet and connect your phone to the WiFi network?


Unfortunately I live in an area where there is still no fiber optic option and the internet access is very slow.
At the moment where I do the tests I do not have network cable to check if the delay is reduced but it is very probable that the sum of both things difficult speed of response
When I can try with the net calbe directly to see that such.
Thanks for the answers


I don’t think that Cayenne demand high quality connection since my phone is using 32 Kbit/s max speed and the App is working fine!