Problem with chart not updating


I’m using a LoRa device connected on My Things Network and an “Analog Input” widget through LPP. I see my data correctly appearing on the dashboard but the chart is not updating anymore since yesterday 1:47 PM CET. Is it a local issue?

Best regards,


Note that I’m using the online web interface.

Hi @thwalewyns

Can you please send me the DevEUI of your device so I can check the logs to make sure everything looks ok.

Also, can you please send a screenshot of what you are seeing?



Hi Camrin,

I sent you a message with some details.

Many thanks,


Hey Thomas,

Sorry for the delayed response.

I checked our logs and everything checks out.

If you are still not able to see your historical data, try refreshing your page and/or clearing your browser cache to give it a fresh start.

The way our graph widget currently works, it will not automatically update in real time, you will need to refresh the page to see the changes. This is something that we are aware of and are working to correct ASAP.

Hi Camrin,

Of course, I understood that I had to refresh the page in order to update the graph widget. I try with an other web browser but the problem is the same. “No data is available for this period”, which is blocked on Jan 01 1:00 AM, as when no data has been received. I will try again with a clearing of my browser cache.

Many thanks for your help,



Ok, so I did a little deeper digging and I have found the issue.

The only way to solve it is to remove your device from the dashboard, and then re-add it. Sorry for the inconvenience.

Thanks for your patience,


Hi there, I also have an issue with historical chart data, 1 day and greater view returns " No Data Available For This Period" and has time set back to 01 Jan. I tried removing and recreating device but this has made no difference. Charts are working well in live, minute and hour view.
Thanks for your assistance

Hi @njones,

How long has the sensor(s) with this data been connected to Cayenne? Some of the longer term views are designed to look like you describe until there is enough data to populate them. Also if you could let me know what the sensors or actuators with this issue are, and how they are connected to Cayenne (Pi, Arduino, MQTT, LoRa).

Hi thanks for getting back to me.

I am using an Arduino, data I am sending back to the dashboard is via virtual pins. Data is accurate for live data, Minute and Hourly views, It is only when I select daily (last24 hours) and greater time periods do I get the message and no data is available. The arduino has been publishing data via the virtual pins for about a week, and at all times the data is available on the shorter time dimensions and is accurate. I am using generic sensors on dashboard and connecting via virtual pins, at the moment I am measuring duration of pump cycles and accumulated run times as well as volumes pumped in cycles and accumulated. If Arduino is powered off all accumulated dashboard values synch to Arduino on start-up, all these processes work well, just unable to see longer time dimensions on charts. I hope this helps.

Thanks, it does. And it means this is not as simple as just ‘not enough data’.

Could you do me a favor and open up the settings page for each widget where the graph has this issue, and then copy for me the URL from your browser while the settings page is open? This will allow me to search our logs for the individual widgets and see if there is any obvious issue on that end. For an example, a URL for one of my sensors looks like this:

Hi there.

Please find 2 separate URLs attached as requested, I have other charts with the same problem but this is aa good sample

Regards and Thanks for your help

This chart refresh bug still hasn’t been fixed. The chart just doesn’t get refreshed.
I’m sending the data via Python MQTT REST API using the example code as given directly from Github.
Other non-chart widgets get updated in real time just fine.

If I switch a chart widget to a value widget, it updates just fine. If I switch back to chart - updates are not working.
The only way to refresh the chart is to press F5.

Using Windows 10. Tested with:

  1. Google Chrome Version 60.0.3112.113 (Official Build) (64-bit)
  2. Opera 47.0.2631.71
  3. Microsoft Edge 38.14393.0.0