Raspberry PI gauges don't produce any charts


#1

Hi. Few days ago I added raspberry pi to my cayenne dashboard. Everything went smooth, gauges are working, what worries me is that when I click chart icon there is nothing in any tab (m, h, d, week) only in live it starts to painting line, but when I refresh page it is lost as well. Long story short, no historical data for me. Tried to convert default gauge widget into line chart widget for one day - did not help. Tried to add another widget on same channel so I ended up with gauge + chart, but didnt work as well. Any idea how to fix that?


#2

can you try removing and re-adding it again? though it will delete all your previous data.


#3

or are you trying to view the history of default raspberry pi temperature?


#4

I tried deleting and adding widgets as well. Doesn’t matter if I am viewing cpu, mem, storage or temp history. All are blank, with no data.


#5

that is because we do not support history data for default raspberry pi widget.


#6

Ok, temperature is not important. I am using RPI as NAS so I am mostly interested in CPU/memory usage to monitor hardware utilisation. Need history for that.


#7

then you will have to manual get the CPU/memory data using python and send it to cayenne using https://github.com/myDevicesIoT/Cayenne-MQTT-Python