(SOLVED) No data received on Cayenne after Re-Integration TTN to Cayenne

I’m still new using Cayenne, recently I just did my TTN App Integration to Cayenne, and I’m surprised that all the widget automatically shown on Cayenne Dashboard. Then I did adding new channel on my Lora Node to have more widget in Cayenne Dashboard. Strange I just cannot add additional widget in the dashboard. Then I decide to do Re-integration of TTN App to Cayenne. At the suddent all the widgets gone from the dashboard, and I cannot see any payload coming to Cayenne.
Status on the TTN as following

  1. On the application side, I can see the payload on the uplink (all normal).
  2. I tried to add 1 additional Lora Node, just incase something wrong with my Lora Node, so I got 2 node registered to TTN now. Both normal in TTN (uplink payload shown in TTN App). Then I create new Device in Cayenne, but still no luck (both payload cannot be shown on Cayenne).
  3. For sure I already tried to delete the Integration in TTN, and delete both Devices in Cayenne, then tried to integrate and register both, and still no luck.
    Please need your support.

Thank you,


To troubleshoot my issue here, I would like to request support from Cayenne Support Team if you guys can check whether my uplink payload from my TTN (2 devices online) are arrived at Cayenne server.
I can’t share the Process ID here (got 1 Process ID per Device), please advice if I can give it privately via email to you. Thank you,

I just delete the default access key, generate new one, and doing re-integration for both devices (TTN Integration into Cayenne). And it still no working. I decide to share the Process ID since it will create new one everytime I did re-integration, ID as following.
Please need your support.

This morning I tried to create new Cayenne login, and adding new devices to the TTN (third one). Register the devices to TTN as usual, and the upload data from 3rd devices shown as normal. Then I add this 3rd devices to this new Cayenne login, and doing integration as on prochedure. And the result is still the same. The 3rd devices on Cayenne doesn’t show any widget and empty data. Any possibility that I messed up my devices firmware during adding new channel for Cayenne? All devices were using same firmware (after adding new channel). I already checked again the firmware (deleting adding new channel lines, so it should be back as before). But the result is still the same. :disappointed_relieved:

I’m just found that I choose wrong Network during Device Selection when registering the device. I was searching for Cayenne LPP and click it directly without checking on which Network. The solution is that I choose TTN Devices first, and then choosing Cayenne LPP, and all things back to normal again now.


I would like to give input, during adding the devices, when I use the Search : “Cayenne”, it only show Cayenne LPP under Acklio, it doesn’t show Cayenne LPP under TTN. So I thought there’s only Cayenne LPP under Acklio, I just don’t realize there’s Cayenne LPP under TTN. I guess it would be better to let new user to select Network first, and then give the new user List of Devices supported under that selected Network. Just my 2 cents.

Hi @lufti.eid,
Glad you figured it out.
And you’re correct, currently, if you just search for a LoRa device, it will default to the first NS on the list.
We do plan on improving this function in the future.