Unable to install cayenne

Before when I executed the command “sudo bash rpi_mgzdbbxrdp.sh -v” I got an error saying
“Failed to stop myDevices.service: Unit myDevices.service not loaded.”
I tried installing it again from the terminal and my android phone. In my andrioid phone I couldn’t see my raspberry pi, so I used the terminal. I followed this link “Unit myDevices.service not loaded” to solve the problem and after executing the commands “sudo /etc/myDevices/uninstall/./uninstall.sh
sudo /etc/webiopi/uninstall/./uninstall.sh”

I tried installing cayenne again but this time another error popped up.

Hi @p.rudra27, welcome to the Cayenne Community!

From your screenshot, it looks like the issue is that you’re trying to download the install file (the wget command) to a directory (/etc) that you don’t have permission to write to, so it’s denying you access to write the file. There are a few ways you can work around this:

  1. [Recommended] Type cd ~ to return to your user home directory which you’ll have write access in, then run the wget and sudo bash commands again.

  2. If you really want to download the installer to /etc, you can enter sudo in front of the wget command to elevate your permissions to write there.