Bug Filed on 04-04-2016: PiFace Digital not adding to dashboard

1. What OS? (Wheezy or Jessie)

Jessie 3/18

2. What class/size SD card? (ex. class 10 16gb)


3. What Model Pi? (A+, A, B+, B, Pi2)

Model B

4. Please describe the bug / issue. Attaching any relevant screenshots would be very helpful! Thanks in advance.

When adding the Piface as a GPIO it will not add saying that there is a bad parameter.

Init got unexpected keyword argument “slave”



Welcome to the Cayenne community!

I don’t believe the PiFace is supported, yet. The latest note I could find is from a month ago-

I’m sure @bestes will jump in here and give us an update on the progress of the PiFace support, I’m in a similar situation with SenseHat.

Again, welcome,



Thank you very much. The only things I could find on here about the Piface were almost a year old. It’s just a SPI expander. I’d be more than happy to write the code if no one has yet! Thanks again!

You found it :open_mouth: It’s not a device that shows up in the add device process unless you actually search for it by typing in the word ‘Pi Face…’ because it’s still going through some testing.

We have a few small fixes we need to do before it works. Thanks for offering to write the code though!

We’re working on a process for allowing people to write code for specific device drivers too.

See you around,


Ha, sweet. Will there be an update notification when it is released? I have a project I would like to use it on. I’ll proto without using Cayenne and use it for the final impl. Thanks!

Sounds good! Yep there will be announcement. I’ll make sure you notified too.

Switching this post back to a Bug so I remember to resolve when this is fixed.


So just out of curiosity, when do you think PiFace will fully functional on Cayenne? It’s one of the main things I was looking forward to when I discovered Cayenne in the first place…

It’s been pushed behind Arduino integration, custom coding, and a few other big features. I’d say within 2 months it will be working in dashboard. (Probably sooner though).



Benny, I see PiFace is showing up on the Add Device menu. I’m guessing that means its ready to go. I’ll order one from Amazon today!


I see it too, but it’s not acting correctly. I tried to add a generic button to set and clear GPIO on the dashboard, but it always fails.

Thanks for the heads up! It’s possible that device is still not quite ready for prime time. Things are still very dynamic here in the Cayenne universe and I know things get better every day.

I did order a PiFace so I will be ready to give it a spin here in a couple days.

Thanks again,


@blsmit5728 @Ian Hold those horses just yet! We released Pi Face when it wasn’t fully integrated into the platform. The fix to get PiFace working has been developed and is waiting in the queue to be released with a batch of fixes etc. once Arduino integration gets out the door. So, hang in there!.. sorry about this.


Thanks for the note Benny! As I said, things are still very fluid in these parts. Looking forward to all the upcoming goodies on the roadmap.


@blsmit5728 @Ian @shortcircuitg4 Hey guys, Pi Face Digital integration has been released. Can you let us know what you think and if you find any issues? Thanks!


Sweet! Mine arrived the other day.

I’m having a tough time keeping up!


Benny now that PiFace is gettin’ some Cayenne love, what about its cousin? Sense Hat wants some of that special Cayenne heat too!

Board is a RPi2b with a fresh image of 2016-05-27-raspbian-jessie.img, expanded / localized. Cayenne installed and PiFace 2 digital mounted. Using web based dashboard.

After adding the PiFace as a GPIO extension I can control the output pins via the extension page by clicking on the port numbers as seen below.

But when I try to add a widget like a relay or even a generic digital output, the widget populates the dashboard and then indicates unreachable.

I have been able to replicate this 3 times from card image through failure.


Thanks @Ian, we’ll look into this. No sense wasting your time trying to do anything else before we thoroughly look at the PiFace I suppose. We’ll get back to you with updates.


Not a ‘waste’ of time. I enjoy the problem solving opportunities!


I’m excited but still I am not able to even add a Piface to my dashboard. When I try adding one it says “failed to add sensor.”