Cayenne disabling my Lora gateway

Hi Team, I was experimenting with the filters in my data tab for my device - Dragino GPS LGT92 v1.4 and when I tried to filter the actual Data Type column it blanked out all my data for my device - selections in the drop down boxes all dissappeared. It stopped updating the overview and my project dashboard. In diagnosing, I saw that data was no longer feeding to TTN from my device, then I saw my gateway had gone offline - it was still running, but not getting any device data. Device had power and was trying to send as normal. A reboot of my gateway fixed the issue and data started flowing again to Cayenne and I could see all the data. I was able to replicate the issue from Cayenne, rebooted my gateway and data is flowing to Cayenne again, but now I can’t see the data in Cayenne (in the data tab) but the device overview and project dashboard is getting updates fine.

This is what I now see in my data:

and this is my overview:

I am using the web UI and a RAK 7258 gateway with TTN Community meshed in Australia.

Thanks
DB

if you not mind losing the history. can you remove the device from cayenne dashboard, wait for some time and re-add.

Yes that worked. I deleted the device, waited a day and added it again.

I have not tried to replicate the error - do you want to take a look or enable some logs or shall I try again?

However, when I added the device to a project, the data is missing from Data tab apart from the latest date stamp. Tacking tab is also not updating

Dashboard overview is updating fine and showing all telemetry with tracking history.

Data in the device looking good.

Project Overview is good.

Nothing to select in Channel or Data Type.

create a new project and re-add the device again.

Yes that worked. I have not touched any of the Data filters yet. Do you want me to try and replicate the error again?

Give it a try.

So, from my project went to data tab and selected Data Type “Batt” - the full list was available and showing. Boom … all data in all columns dissappears - except the time stamp in first column. Tried all options to bring it back - nothing. The selection list is Data Type has no items to select. Checked the device is selected in Device Name column. Can’t select anything in Channels. All Sensor names & ID are showing and selected.

Next I went to the Device Overview and Data and all was still showing. Tried same Data Type selection of “Batt” and same result - all data goes blank.

Data is still flowing though - I can see it updating on the Project Overview and location history is still available.

So its no longer impacting on TTN and my gateway - that’s an improvement.

However, not really a sustainable solution for me to have to delete my device and project each time this happens.

can you private message me your email id, so i can check it at my end.